Wednesday, 29 April 2009

A Weird Little Quirk with Windows 7, Outlook 2007 and NormalEmail.dotm

One of those “get this fix into Google” blog posts… running Outlook 2007 on Windows 7 Beta, whenever i close Outlook I get this error message:

image

Outlook cannot save or create this file. Make sure that the disk you want to save the file on is not full, write-protected, or damaged. (C:\NormalEmail.dotm)

It’s actually trying to create NormalEmail.dotm under

C:\Users\user.name\AppData\Roaming\Microsoft\Templates\

but for some reason I don’t understand, after installing Office 2007 on Windows 7, there’s a weird 100Kb file called simply “Templates” – no extension - in C:\Users\user.name\AppData\Roaming\Microsoft\. It doesn’t do anything as far as I can tell, but it means Outlook can’t create the Templates\ folder because there’s already a file by that name in the AppData\Roaming\Microsoft\ folder. Deleting this file doesn’t appear to hurt anything, and once it’s gone, Outlook happily shuts down without complaint.

That’s been bugging me for weeks, so I’ll bet you it’s fixed in yesterday’s Office 2007 Service Pack 2, or the Windows 7 Release Candidate that’s due out tomorrow… but if it’s not, then this is how I fixed it :)

6 comments:

Tariq said...

I am having the same issue, please let me know if somebody knows about the remedy or work around for this.

Thanks.
Tariq

Tariq said...

Right click on Outlook.exe and run it as administrator.

You won't get this error again.

Thanks.
Tariq

Alex said...

For work with outlook files there are a lot of programs,which recover mails.But once my girlfriend had the unpleasant problem and these tool couldn't help me.Fortunately i found good program-ost pst convert.And it solved my issues and made it free of cost.In addition software showed how repair your data and convert it to *.pst format, that can be easily opened by any email client, compatible with Microsoft Outlook.

Anonymous said...

Worked Great for me on 4/3/11!!!

Javen said...

This worked perfectly for me, thanks for the post. Now I need to get my scripting on....

Anonymous said...

we had the same issue. this was because of a script that was ment to copy a template file to the templates folder. In stead is renamed the templates folder name to the templates name.

we fixed the script and all works well.